Home

The CJ2A Page Message Board


(Click RELOAD after posting to see your message.) 

NOTE: I am cleaning out the Message Board, and am creating a new page called Questions and Answers that contains information gleaned from this forum.

Questions and Answers | Return to The CJ2A Home Page
Low Oil Pressure

[ Follow Ups ] [ Post Followup ] [ ]

Posted by Ryp on November 16, 2002 at 11:32:33:

(thread renew)


Ok, I've checked the line-to-guage situation and that line is clear and guage is working properly. Still getting a reading of about 2psi (fresh engine rebuild/restart problems here). The line from the oil filter canister that drains into the timing case was plugged and is since been replaced with new. After these measures the reading is still way low for a new engine....2psi.


Question: Could it be that I've been given another oil pump that bolts up but doesnt possibly have the holes/ports lining up like the original? I regret throwing out the old one :(.


Question #2: The oil galley has a plug (for clean-out?) that's near the #2cyl area and it's in place. Could there be another plug somewhere in the oil system that I'm missing here?? Seems like I've got it boiled down to either a massive leak draining oil back into pan or the pump isnt circulating strongly as it should. I dont think it's a bearing clearance prob because even then it should produce 20psi or so.

Thanx!
Ryp


Follow Ups



Post Followup

Name:
E-Mail:

Subject:

Message:

Optional Link URL:
Link Title:
Optional Image URL:


[ Follow Ups ] [ Post Followup ] [ ]